Network Reliability Engineering Community

Accessing lessons on local Antidote setup

I am planning to add a JET lesson [https://github.com/nre-learning/nrelabs-curriculum/issues/226] and for that activity I was going through documentation to have my own local Antidote setup to try things out, so far I’ve been trying in a vMX VM setup.

I followed this page for download and installation of necessary software
https://antidoteproject.readthedocs.io/en/latest/building/local.html#buildlocal

After the webservice is up I can access the NRE labs main page http://192.168.99.102:30001/advisor/index.html but I see that the Lesson Catalogue section is all grey’ed out and I wasn’t able to access the lesson content, I could be missing something simple, any ideas?

I did download the curriculum which is at the same level as antidote-selfmedicate.
ram-mbp-machine:antidote-local ram$ ls
antidote-selfmedicate nrelabs-curriculum

That is not the correct URL. The selfmedicate script modifies your /etc/hosts file for a reason, so that you can access Antidote via the antidote-local name. Please follow the output given by that script.

Also, for future reference we have a separate category for Antidote issues (“Antidote Support”). I’ll move this topic for you.

Hi @sivarambattu,

If you don’t see any entry in /etc/hosts for antidote-local, add the entry manually with the respective IP address (in your case It is 192.168.99.102) and then access http://antidote-local:30001/advisor/index.html .

I see you are using a Mac… since you posted this, some fixes were made for selfmedicate in Mac. Try recloning the repository and launching again.

Thank you Matt, Pradeep, Derick,

I am able to see the lessons now.

I was hitting this error during ./selfmedicate.sh resume



About to modify /etc/hosts to add record for ‘antidote-local’ at IP address 192.168.99.102.
You will now be prompted for your sudo password.
Password:
sed: 1: “/etc/hosts”: extra characters at the end of h command

I read that the sed BSD vs GNU versions differ particularly for inline editing, I was about to try modifying that but I see that it is fixed in latest selfmedicate.sh.

This is fixed for ‘start’ option to selfmedicate.sh but not for ‘resume’ though, I changed that in my local setup after that I am able to browse lesson content.

Ah - we’ll have to extend that fix to all instances of sed. Thanks

Hi Matt,


Should I wait for this change to complete and then update my local Antidote setup with new changes before I start the addition of my lesson [https://github.com/nre-learning/nrelabs-curriculum/issues/226] ?

Thanks,
-Ram.

You can do whatever you want. However, when that issue is closed, the latest tag for the syringe image used in selfmedicate will be updated with the change, and you’ll have to update your lesson metadata to reflect it. It’s not a lot of work, so if I were you, I’d proceed as normal, but understand you might have to make some changes in the near future.

This is unrelated, however, to the original purpose of this thread so if you have any other questions please use that issue for further discussion on it.